Heat bed connector tips


If you own one of the popular Anet A8 3D printers, you have probably read about or experienced the dreaded burnt heat bed connector.  In this post I will talk about how and why this happens, and ways to fix or even prevent this before it becomes a problem.

Burnt heat bed connector

What is this and how does it happen

In the image seen above, the brown area on the side of the connector is heated burnt plastic.  This is caused from the metal connector inside the plastic housing getting hot.  Why does this get hot you ask?  The root cause of this problem is movement of the connector due to the wires not being secured.  As the printer is printing and moving forward and back, the wires are constantly moving from side to side.  This movement puts stress on the connectors inside the plastic housing as they are connected to the pin causing micro gaps between the connectors and the pins.  Because of these gaps the high current traveling through the connector arcs across these gaps.  Every time an arc happens, a small amount of oxidation builds up at the point where the arc happened.  As the connector continues to arc and the oxidation on the connector and pin builds up, this causes resistance.  With resistance and high current comes heat. The more the movement, the more arcing.  The more arcing the more oxidation buildup.  The more oxidation buildup the higher the resistance.  The higher the resistance, the more heat.  All this until the connector can't take it any more.  If it gets bad enough, this can start a fire.

3D printer fire

A fundamental cause of the problem

Heat bed connectorThe Anet A8 printer has a fundamental design flaw in the heat bed connector from the get go that can increase the chances of the connector heating up and burning out.  The connector used on the heat bed is a VHR-6N manufactured by JST.  The easiest is to buy a pre-made harness rather than the connector.  If you just buy the connector, then you have to have the proper crimper to attach the connectors.  There are not a lot of companies that sell a full harness that I have found.  They can be found on ebay though.  Just do a search for "JST VHR-6N harness".  You can usually get them in 1 or 2 foot lengths.  Next, if you look at the data sheet for this connector (http://www.jst-mfg.com/product/pdf/eng/eVH.pdf), it has a rating of 10 amps.  That is 10 amps per pin which is close to what the heat bed draws, actually a little less.  The heat bed has a resistance of around 1 ohm, and according to ohms law, current = voltage / resistance, so at 12 volts, the heat bed should draw approximately 12 amps. The connector has 6 pins, but the manufacturers of the Anet A8 decided to only use 4 of the 6 pins with their wiring.  The outer two pins are the power connections for the bed, and the middle two pins are for the heat bed thermistor.  Because of this, there is a potential 12 am draw on a pin rated for only 10 amps.  The ideal connection would be to use the outer TWO pins on each side, marked + + and - - on the image.  Using two wires for each spreads that 12 amps evenly over the 2 pins.  Therefore you get a current of 6 amps on each pin which is 4 amps less than what they are rated for which is MUCH safer.

How to fix the problem

I see SO MANY PEOPLE out there that say that the fix for this problem is to add a MOSFET to your power connections for your heat bed.  This is NOT the answer.  So you may ask, how do I fix this issue.  Fixing this issue requires addressing the two problems discussed here, motion of the wire causing arcing, and spreading the connection of the wires on the heat bed across both positive and both negative connector pins to even out the distribution of the current that the heat bed draws.

Heat bed strain reliefThe first one is easy to deal with, and that is with the use of strain relief on the wire preventing it from moving the connector.  This can be something as simple as using a binder clip to hold the wire to the bed, to a bit more complex using the Y axis cable chain mod.  Basically anything that can keep the wire from moving the connector around while printing should work.

The next is to modify or replace the heat bed connector.  One mod can be seen in the image above which uses spade connectors that will connect between the two positive and the two negative pins on the connector and using the stock wire.Replacement heat bed connector  Another option is to buy a replacement heat bed connector that has all four wires and connecting both positives and both negatives together at the heat bed connection point, be that at the main board or  mosfet if you have done such a mod.


I hope you found this information informative.  I wrote this in the hopes that it can help new Anet users prevent some of the issues that can arise, as well as helping users that have ran into these problems to figure out the best fix for their situation.  In any case, happy 3D printing and I hope you get years of use out of your Anet printer.

Related Images:

One Reply to “Heat bed connector tips”

  1. DUDE !!!

    Thank you LOADS for posting such great detailed reasons for WHY this nonsense is happening in thefirst place, i alsohave an Anet A8 due to being at a stupidly low income bracket, so couldnt afford better, although i did buy some mosFET modules, a few rolls of ABS and a 12/24v dual power Heatbed to replace the one that came with the Anet A8…

    This happened to me exactly as your photo showed, but it was the negative wire (Black) that was just-starting to burn through the white plastic connector..

    So as i didnt have any other wire of suitable gauge, i cut the wire that came with the Anet A8 with the Hot-Bed connector and cut it in half, so now using the original gauge wiring i doubled up the Positive and Negative wires to the hotbed then soldered them directly to the crimped wire connectors that plug into the mosfet module, then mosfet module to the PSU

    Now no more burning smells and i used clear heat-shrink over the plastic white connector to watch it over time to make sure theres no more burning..

    I will want to use a separate PSU for the hotbed, i think i have a 10 or 15 amp PSU somewhere, so theres less strain on the Anet A8 supplied PSU, i do have a 120mm Fan on the main PSU on at all times and it switches off 2-3 minutes after main power is switched off to cool the PSU till its around ambient 🙂

    Once again – a HUGE Thank You for this, your blog is awesome ! Please keep up the great and inspiring work that helps us financially-challenged folk hehe 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *

WordPress spam blocked by CleanTalk.